System Requirements - Maya


Pre-requisites and Minimum Requirements


For Maya 2016-2018, Komotion is dependent on .NET Framework 4.6.2, which will automatically be installed if it is not already present on the workstation. For Maya 2019+, Komotion is dependent on .NET Framework 4.8. Offline standalone installers for .NET Framework 4.6.2 and 4.8 are provided alongside the installers.


For minimum Maya requirements, some versions of Maya (for example, Maya 2018 with Update 2) are not supported, as they have had issues that prevent correct operation of the Komotion plug-ins. It is recommended that Users ensure before Komotion installation that they have the appropriate updates installed for Maya. Maya LT is not supported. macOS and Linux are not supported. 32-bit Windows operating systems are not supported.


Komotion (Maya 2016 Ext. 2)

Komotion (Maya 2017)

Komotion (Maya 2018)

Komotion (Maya 2019)


Maya: Autodesk Maya 2016 Extension 2


Maya: Autodesk Maya 2017 Update 4+


Note:  Due to fixes in Maya 2018 Update 4, Maya 2017 Update 3 and earlier are not supported.

Maya: Autodesk Maya 2018 Update 3+

Note: Due to fixes in Maya 2018 Update 3, Maya 2018 Update 2 and earlier is not supported.

Maya: Autodesk Maya 2019


System Requirements


The system requirements for the Komotion for Maya plug-ins should be regarded as the associated minimum system requirements for the host Maya software. Below are the general minimum system requirements for recent Autodesk Maya releases, with some notes:


OS: Windows 7 SP1, Windows 8.1, Windows 10

CPU: 64-bit Intel® or AMD® multi-core processor with SSE4.2 instruction set

RAM: 8 GB RAM*

Disk Space: 25MB disk space for installation

Network adapter and Internet access for Online license activation**


* For complex character rigs in large scenes, we recommend at least 16GB RAM.

** Offline license activation is also available through Komotion Support. Internet access may also be required for downloading and installing dependencies.